Tribes2.exe - Entry Point Not Found


It's been a lot of years since I've played Tribes 2, and wanted to boot it up on my PC. I'm on Win 10, btw.

After installing the GS version and patching the game with the TribesNEXT patch, I've tried using the "Tribes 2 Online" shortcut, but got the following error:

"Tribes2.exe - Entry Point Not Found

The procedure entry point _except handler4_common could not be located in the dynamic link library C:\Windows\System32\SHLWAPI.dll.

The procedure entry point _except handler4_common could not be located in the dynamic link library C:\Windows\System32\ADVAPI32.dll

The procedure entry point _except handler4_common could not be located in the dynamic link library C:\Windows\System32\WINMM.dll

The procedure entry point _except handler4_common could not be located in the dynamic link library C:\Windows\System32\AVIFIL32.dll

The procedure entry point _except handler4_common could not be located in the dynamic link library C:\Windows\System32\WSOCK32.dll"

I've already tried following guides on Google that told me to use the "sfc scannow" command for fixing corrupt files, or to re-register files, but to no avail - nothing worked.

I've even tried going on the Tribes 2 Discord chat, but they promptly accused me of being a stupid hacker because they were sure that error meant I was installing hacks in my Tribes 2 game. I don't freakin' care about hacks, cheats, or winning, I just want to play a game that I've played when I was a teenager and worry-free, damn. They even banned and re-admitted me after I've plead my cause, but hell, sometimes they still warned me that if I get caught using aimbots they'll ban me again.

What do I need to do to let people believe me that I just want to make my Tribes 2 installation work?

Oh, btw, rant ended. The other thing is that the game works perfectly on my laptop with Win11, but I'd like to make it work on my desktop, so I'd want to fix this issue. On the web I didn't find anything relating this error to Tribes 2, so I don't really know what to do right now.

Thanks in advance!


  • Your C library runtime MSVCRT.DLL may be missing or damaged/corrupt -- although this DLL is managed by and comes standard with the operating system, and its absence should cause similar issues running any 32-bit application.

    If you are in fact using a 32-bit build of the OS (if those aren't virtual paths in the error messages), it will be in System32 and you could look for it there, but if you're running a 64-bit version of Windows, 32-bit applications will be loading the library from C:\Windows\SysWOW64\msvcrt.dll

    I'm not certain offhand whether installing the redistributables will touch this library since it's meant to be included in the Windows image (and thus nominally repaired by tools like sfc/dism), but you can try updating the latest runtimes here:

  • Thanks for the fast reply.

    I'm running the 64-bit version of Windows 10, that's the strange thing. Is the game trying to run stuff from my System32 folder instead of the SysWOW64?

    I'll try to install the latest runtimes when I get home and update you on what happens, thank you!

  • edited July 6

    Nah, if you're running on a native 64-bit desktop version of Windows and haven't done any insane modifications, it's definitely loading from SysWOW64. WoW64 shims a translation layer so that whenever a 32-bit program believes it's linking a DLL from System32, it'll actually be redirected to SysWOW64. The redirected path string just wouldn't be something the runtime would keep track of, which makes it a little unclear if they're reported in errors. "System32" now contains only the 64-bit variants of the libraries, so they'll never be directly loaded by a 32-bit application.

  • Ok, still no luck, unfortunately.

  • As I mentioned, those redistributables might not touch that file since it's managed as part of the operating system updates, so it was a long shot. Nothing relating to the game itself actually requires anything that isn't provided in the OS by default these days.

    Regardless, this is something unique to your configuration, whether it's a problem with your system MSVCRT (which exports the indicated symbol for more recent versions of the compiler than were used to build the game), or an issue with each of the DLLs mentioned in your error messages. It's possible you have third-party driver or other software loading into the process in an unusual way, or something as minor as that you've unknowingly edited the known dlls registry config causing it to try loading MSVCRT.dll from the gamedata directory... Without being able to observe/reproduce specifically what's happening with debugging tools, the most likely case feels like your Windows installation may just be broken.

    You mentioned you used sfc, but did it find anything? Did you use DISM as well? You could conceivably try copying the affected files from a working system, but at some point it might be quicker just to try a reinstall.

  • Yep, I've used sfc and DID find corrupted files. It said that it repaired them, but nothing really changed - still got the error while launching Tribes 2.

    Also, I just did try DISM, but to no avail, unfortunately. I'll try copying the files from one of my other PCs, I didn't think of that.

    Thanks again!

Sign In or Register to comment.